Jump to content

vote help


Beefstorm
 Share

Recommended Posts

Ok i am a noob to this server and when i went to turn in vote points it tells me i need litch king to do that. I thought this was a cata server where u only need cata to play all aspects of the game . The other problem is when i try to purchase a mount i am told i need another wow version. So i need some real help thanks anyone who can help on this

Link to comment
Share on other sites

Sounds like something's wrong with either your WoW version, or your entire client.

What version of WoW are you using exactly? 

Could you perhaps write down the exact messages you get when trying to purchase a mount and spend vote points?

 

The easiest fix would probably be to download the IceCold Launcher from here and use it to reinstall, but maybe there's a faster fix which I am yet to figure out.

Link to comment
Share on other sites

I have downloaded the launcher so that's not the problem. So at the auction house im told that it requires expansion cataclysm to do that. when you go to the vote shop weapons/gear<trade in your tokens> it says requires expansion Wrath of the litch king, When at the horde mall bobdole says requires expansion burning crusade. So nothing will even let me open to see gear mounts etc to purchase. cuz  of this. Im also on cata version 4.3.4

Link to comment
Share on other sites

what panel is that I don't understand what you mean by that. The only panel I know of is when in game where you pull up to log out and if that's what you mean I don't see what your meaning. sorry about this like I said im new to this I have only played vanilla classic wow. so im very very new to all of this.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...