Jump to content

Do not upgrade to 5.0


Rocx
 Share

Recommended Posts

  • Owners

Do not upgrade your WoW install to 5.0.4 if you want to continue playing IceCold.

IceCold does NOT support 5.x and probably will not for a long time. If you want to play MoP, please make a copy of your WoW folder and only upgrade one of them, so you can still play this server.

If you have already upgraded, download 4.0.6 from here: http://194.71.107.80/torrent/7005814/World_of_Warcraft__Cataclysm

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...