Jump to content
  • 0

Need help with an issue.


adavey008
 Share

Question

Hey, so i'm new here and well i login fine and stuff but soon as i log in like at first i thought it was terror lag... but i actually think it's just really faecesty fps lag and well my pc isn't bad at all i don't know why it's like this. So is there a way to fix this other than maybe get an even better pc somehow..i don't know but i have a feeling it's to do with all the custom items maybe?

Anyway if i can get some help would be nice. If it can't be fixed then i guess i can't play here sorry :\

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

well i'll try.. i mean i can run retail on full settings and its fine, but this is weird like it starts of fine then i get thsi huge like fps drop or lag spike and the game just doesnt respond unless i wait long enough or it just "program is not responding" but i'll give it a try, thanks for the help.

Link to comment
Share on other sites

  • 0

I'm well aware that fps has nothing to do with the server, however i can't get my head around how i can run wow in ultra on live in orgrimmar yet i cant seem to play a clean game on this server against 3 mobs on low settings..just doesn't make sense.. probably just all the custom stuff everyone making wow hate itself

--------

Wonder if i see if my drivers need updating if that would help.. worth a shot atleast :\

Link to comment
Share on other sites

  • 0

Try disabling some addons. I have some past experience with addons making the game extremely choppy. Whenever I have recount on, this happens to me. I can barely even move or it'll have a terrible lag spike.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...