Jump to content
  • 0

I need help


Freemind
 Share

Question

So before this new core got added the game loaded fine and all. But now i gotta download game content, if i mouse over Game menu, far down on my screen it says "Downloading 2% complete" and whenever i put gear on, my char litterally gets invisible for me, and sometiems i do not see npcs hats or pieces off armor doesn't load etc etc.

So.. ive checked my retail launcher before i started and it says "wow is up to date" so i dunno why i get this issue. I have done the remove patch with the icecoldlauncher, i tried to download a new one and see if it fixed it but.. no.

So any ideas or tips or sumthing?

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...